2000人QQ群 : 67842417
Join us if you will.

Ubuntu 16.04安装sogou 拼音输入法

首先到官网下载搜狗拼音输入法
sogou 拼音输入法
http://pinyin.sogou.com/linux/?r=pinyin

当前下载的版本是sogoupinyin_2.0.0.0078_amd64.deb

如果直接使用dpki安装会报错,具体如下:

点击(此处)折叠或打开

  1. $ sudo dpkg –i sogoupinyin_2.0.0.0078_amd64.deb
  2. Selecting previously unselected package sogoupinyin.
  3. (Reading database ... 211651 files and directories currently installed.)
  4. Preparing to unpack sogoupinyin_2.0.0.0078_amd64.deb ...
  5. Unpacking sogoupinyin (2.0.0.0078) ...
  6. dpkg: dependency problems prevent configuration of sogoupinyin:
  7.  sogoupinyin depends on libopencc2 | libopencc1; however:
  8.   Package libopencc2 is not installed.
  9.   Package libopencc1:amd64 is not installed.
  10.  sogoupinyin depends on fcitx-libs (>= 4.2.7); however:
  11.   Package fcitx-libs is not installed.
  12.  sogoupinyin depends on fcitx-libs-qt (>= 4.2.7); however:
  13.   Package fcitx-libs-qt is not installed.
  14. dpkg: error processing package sogoupinyin (install):
  15.  dependency problems – leaving unconfigured
  16. Processing triggers for mime-support (3.59ubuntu1) ...
  17. Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160701-0ubuntu1) ...
  18. Rebuilding /usr/share/applications/bamf-2.index...
  19. Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
  20. Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
  21. Processing triggers for shared-mime-info (1.5-2ubuntu0.1) ...
  22. Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
  23. Processing triggers for libglib2.0-0:amd64 (2.48.1-1~ubuntu16.04.1) ...
  24. No such key ‘Gtk/IMModule’ in schema ‘org.gnome.settings-daemon.plugins.xsettings’ as specified in override file ‘/usr/share/glib-2.0/schemas/50_sogoupinyin.gschema.override’; ignoring override for this key.
  25. Errors were encountered while processing:
  26.  sogoupinyin

这是缺少一些依赖包,使用如下命令安装依赖:
sudo apt install libopencc1 fcitx-libs fcitx-libs-qt

具体如下:

点击(此处)折叠或打开

  1. $ sudo apt install libopencc1 fcitx-libs fcitx-libs-qt
  2. Reading package lists... Done
  3. Building dependency tree
  4. Reading state information... Done
  5. The following package was automatically installed and is no longer required:
  6.   fonts-noto-mono
  7. Use ‘sudo apt autoremove’ to remove it.
  8. The following NEW packages will be installed:
  9.   fcitx-libs fcitx-libs-qt libopencc1
  10. 0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
  11. Need to get 622 kB of archives.
  12. After this operation, 9,114 kB of additional disk space will be used.
  13. Get:1 http://ubuntu.cn99.com/ubuntu xenial/universe amd64 libopencc1 amd64 0.4.3-2build1 [614 kB]
  14. Get:2 http://ubuntu.cn99.com/ubuntu xenial/universe amd64 fcitx-libs all 1:4.2.9.1-1ubuntu1 [3,818 B]
  15. Get:3 http://ubuntu.cn99.com/ubuntu xenial/universe amd64 fcitx-libs-qt all 1:4.2.9.1-1ubuntu1 [3,790 B]
  16. Fetched 622 kB in 0s (1,929 kB/s)
  17. Selecting previously unselected package libopencc1:amd64.
  18. (Reading database ... 211651 files and directories currently installed.)
  19. Preparing to unpack .../libopencc1_0.4.3-2build1_amd64.deb ...
  20. Unpacking libopencc1:amd64 (0.4.3-2build1) ...
  21. Selecting previously unselected package fcitx-libs.
  22. Preparing to unpack .../fcitx-libs_1%3a4.2.9.1-1ubuntu1_all.deb ...
  23. Unpacking fcitx-libs (1:4.2.9.1-1ubuntu1) ...
  24. Selecting previously unselected package fcitx-libs-qt.
  25. Preparing to unpack .../fcitx-libs-qt_1%3a4.2.9.1-1ubuntu1_all.deb ...
  26. Unpacking fcitx-libs-qt (1:4.2.9.1-1ubuntu1) ...
  27. Setting up libopencc1:amd64 (0.4.3-2build1) ...
  28. Setting up fcitx-libs (1:4.2.9.1-1ubuntu1) ...
  29. Setting up fcitx-libs-qt (1:4.2.9.1-1ubuntu1) ...
  30. Processing triggers for libc-bin (2.23-0ubuntu3) ...

然后安装

点击(此处)折叠或打开

  1. $ sudo dpkg –i sogoupinyin_2.0.0.0078_amd64.deb
  2. Selecting previously unselected package sogoupinyin.
  3. (Reading database ... 211686 files and directories currently installed.)
  4. Preparing to unpack sogoupinyin_2.0.0.0078_amd64.deb ...
  5. Unpacking sogoupinyin (2.0.0.0078) ...
  6. Setting up sogoupinyin (2.0.0.0078) ...
  7. Processing triggers for mime-support (3.59ubuntu1) ...
  8. Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160701-0ubuntu1) ...
  9. Rebuilding /usr/share/applications/bamf-2.index...
  10. Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
  11. Processing triggers for desktop-fileutils (0.22-1ubuntu5) ...
  12. Processing triggers for shared-mime-info (1.5-2ubuntu0.1) ...
  13. Processing triggers for hicolor-icontheme (0.15-0ubuntu1) ...
  14. Processing triggers for libglib2.0-0:amd64 (2.48.1-1~ubuntu16.04.1) ...
  15. No such key ‘Gtk/IMModule’ in schema ‘org.gnome.settings-daemon.plugins.xsettings’ as specified in override file ‘/usr/share/glib-2.0/schemas/50_sogoupinyin.gschema.override’; ignoring override for this key.

总结一下安装步骤,两步即可

点击(此处)折叠或打开

  1. sudo apt install libopencc1 fcitx-libs fcitx-libs-qt
  2. sudo dpkg –i sogoupinyin_2.0.0.0078_amd64.deb

下面选择输入法:
1.在Language Support中增加汉语,然后选择输入法系统为fcitx
2.重启系统
3.在Text Entry中增加Sogou Pinyin
4.使用Ctrl+space即可开启搜狗输入法

Leave a comment

电子邮件地址不会被公开。 必填项已用*标注